本网页所有文字内容由 imapbox邮箱云存储,邮箱网盘, iurlBox网页地址收藏管理器 下载并得到。
ImapBox 邮箱网盘 工具地址: https://www.imapbox.com/download/ImapBox.5.5.1_Build20141205_CHS_Bit32.exe
PC6下载站地址:PC6下载站分流下载
本网页所有视频内容由 imoviebox边看边下-网页视频下载, iurlBox网页地址收藏管理器 下载并得到。
ImovieBox 网页视频 工具地址: https://www.imapbox.com/download/ImovieBox4.7.0_Build20141115_CHS.exe
本文章由: imapbox邮箱云存储,邮箱网盘,ImageBox 图片批量下载器,网页图片批量下载专家,网页图片批量下载器,获取到文章图片,imoviebox网页视频批量下载器,下载视频内容,为您提供.
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree. Input Specification: Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack. Output Specification: For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line. Sample Input:
Sample Output:
简单的模拟
03-3. Tree Traversals Again (25)
Figure 16 Push 1 Push 2 Push 3 Pop Pop Push 4 Pop Pop Push 5 Push 6 Pop Pop
3 4 2 6 5
#include <iostream>
#include <algorithm>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include<queue>
#include<stack>
#include<map>
#include<set>
using namespace std;
#define lson ((root<<1))
#define rson ((root<<1)+1)
#define MID ((l+r)>>1)
typedef long long ll;
typedef pair<int,int> P;
#define For(i,t,n) for(int i=(t);i<(n);i++)
const int maxn=20001;
const int base=1000;
const int inf=9999999;
const double eps=1e-5;
int T[maxn];
int f[maxn];
int n;
int first=1;
void post(int root)
{
if(T[lson]!=-1)
post(lson);
if(T[rson]!=-1)
post(rson);
if(first)
{
first=0;
printf("%d",T[root]);
}
else
printf(" %d",T[root]);
}
int main()
{
int m,i,j,k,t;
cin>>n;
memset(T,-1,sizeof(T));
//memset(f,0,sizeof(f));
n*=2;
string a;
stack<int> s;
int root=1;
cin>>a>>t;
T[1]=t;
s.push(t);
int ok=1;
for(i=1; i<n; i++)
{
cin>>a;
if(a=="Push")cin>>t;
if(a=="Push")
{
s.push(t);
if(ok)
{
T[lson]=t;
root=lson;
}
else
{
T[rson]=t;
root=rson;
ok=1;
}
}
else if(a=="Pop")
{
int tmp=s.top();
for(j=0;j<maxn;j++)
if(T[j]==tmp)break;
root=j;
s.pop();
ok=0;
}
}
post(1);
printf("/n");
return 0;
}
阅读和此文章类似的: 程序员专区